C# Class java.security.spec.ECParameterSpec

Inheritance: java.lang.Object, AlgorithmParameterSpec
Exibir arquivo Open project: JeroMiya/androidmono

Public Methods

Method Description
ECParameterSpec ( java arg0, java arg1, java arg2, int arg3 )
getCofactor ( ) : int
getCurve ( ) : global::java.security.spec.EllipticCurve
getGenerator ( ) : global::java.security.spec.ECPoint
getOrder ( ) : global::java.math.BigInteger

Protected Methods

Method Description
ECParameterSpec ( global @__env )

Private Methods

Method Description
ECParameterSpec ( )

Method Details

ECParameterSpec() protected method

protected ECParameterSpec ( global @__env )
@__env global

ECParameterSpec() public method

public ECParameterSpec ( java arg0, java arg1, java arg2, int arg3 )
arg0 java
arg1 java
arg2 java
arg3 int

getCofactor() public method

public getCofactor ( ) : int
return int

getCurve() public method

public getCurve ( ) : global::java.security.spec.EllipticCurve
return global::java.security.spec.EllipticCurve

getGenerator() public method

public getGenerator ( ) : global::java.security.spec.ECPoint
return global::java.security.spec.ECPoint

getOrder() public method

public getOrder ( ) : global::java.math.BigInteger
return global::java.math.BigInteger