C# Class java.security.spec.ECParameterSpec

Inheritance: java.lang.Object, AlgorithmParameterSpec
Afficher le fichier Open project: JeroMiya/androidmono

Méthodes publiques

Méthode Description
ECParameterSpec ( java arg0, java arg1, java arg2, int arg3 )
getCofactor ( ) : int
getCurve ( ) : global::java.security.spec.EllipticCurve
getGenerator ( ) : global::java.security.spec.ECPoint
getOrder ( ) : global::java.math.BigInteger

Méthodes protégées

Méthode Description
ECParameterSpec ( global @__env )

Private Methods

Méthode Description
ECParameterSpec ( )

Method Details

ECParameterSpec() protected méthode

protected ECParameterSpec ( global @__env )
@__env global

ECParameterSpec() public méthode

public ECParameterSpec ( java arg0, java arg1, java arg2, int arg3 )
arg0 java
arg1 java
arg2 java
arg3 int

getCofactor() public méthode

public getCofactor ( ) : int
Résultat int

getCurve() public méthode

public getCurve ( ) : global::java.security.spec.EllipticCurve
Résultat global::java.security.spec.EllipticCurve

getGenerator() public méthode

public getGenerator ( ) : global::java.security.spec.ECPoint
Résultat global::java.security.spec.ECPoint

getOrder() public méthode

public getOrder ( ) : global::java.math.BigInteger
Résultat global::java.math.BigInteger