C# Class java.security.spec.DSAPublicKeySpec

Inheritance: java.lang.Object, KeySpec
Mostrar archivo Open project: JeroMiya/androidmono

Public Methods

Method Description
DSAPublicKeySpec ( java arg0, java arg1, java arg2, java arg3 )
getG ( ) : global::java.math.BigInteger
getP ( ) : global::java.math.BigInteger
getQ ( ) : global::java.math.BigInteger
getY ( ) : global::java.math.BigInteger

Protected Methods

Method Description
DSAPublicKeySpec ( global @__env )

Private Methods

Method Description
DSAPublicKeySpec ( )

Method Details

DSAPublicKeySpec() protected method

protected DSAPublicKeySpec ( global @__env )
@__env global

DSAPublicKeySpec() public method

public DSAPublicKeySpec ( java arg0, java arg1, java arg2, java arg3 )
arg0 java
arg1 java
arg2 java
arg3 java

getG() public method

public getG ( ) : global::java.math.BigInteger
return global::java.math.BigInteger

getP() public method

public getP ( ) : global::java.math.BigInteger
return global::java.math.BigInteger

getQ() public method

public getQ ( ) : global::java.math.BigInteger
return global::java.math.BigInteger

getY() public method

public getY ( ) : global::java.math.BigInteger
return global::java.math.BigInteger