C# Class java.security.spec.RSAPrivateCrtKeySpec

Inheritance: java.security.spec.RSAPrivateKeySpec
Show file Open project: JeroMiya/androidmono Class Usage Examples

Public Methods

Method Description
RSAPrivateCrtKeySpec ( java arg0, java arg1, java arg2, java arg3, java arg4, java arg5, java arg6, java arg7 )
getCrtCoefficient ( ) : global::java.math.BigInteger
getPrimeExponentP ( ) : global::java.math.BigInteger
getPrimeExponentQ ( ) : global::java.math.BigInteger
getPrimeP ( ) : global::java.math.BigInteger
getPrimeQ ( ) : global::java.math.BigInteger
getPublicExponent ( ) : global::java.math.BigInteger

Protected Methods

Method Description
RSAPrivateCrtKeySpec ( global @__env )

Private Methods

Method Description
RSAPrivateCrtKeySpec ( )

Method Details

RSAPrivateCrtKeySpec() protected method

protected RSAPrivateCrtKeySpec ( global @__env )
@__env global

RSAPrivateCrtKeySpec() public method

public RSAPrivateCrtKeySpec ( java arg0, java arg1, java arg2, java arg3, java arg4, java arg5, java arg6, java arg7 )
arg0 java
arg1 java
arg2 java
arg3 java
arg4 java
arg5 java
arg6 java
arg7 java

getCrtCoefficient() public method

public getCrtCoefficient ( ) : global::java.math.BigInteger
return global::java.math.BigInteger

getPrimeExponentP() public method

public getPrimeExponentP ( ) : global::java.math.BigInteger
return global::java.math.BigInteger

getPrimeExponentQ() public method

public getPrimeExponentQ ( ) : global::java.math.BigInteger
return global::java.math.BigInteger

getPrimeP() public method

public getPrimeP ( ) : global::java.math.BigInteger
return global::java.math.BigInteger

getPrimeQ() public method

public getPrimeQ ( ) : global::java.math.BigInteger
return global::java.math.BigInteger

getPublicExponent() public method

public getPublicExponent ( ) : global::java.math.BigInteger
return global::java.math.BigInteger