C# Class java.security.spec.RSAMultiPrimePrivateCrtKeySpec

Inheritance: java.security.spec.RSAPrivateKeySpec
Show file Open project: JeroMiya/androidmono

Public Methods

Method Description
RSAMultiPrimePrivateCrtKeySpec ( java arg0, java arg1, java arg2, java arg3, java arg4, java arg5, java arg6, java arg7, java arg8 )
getCrtCoefficient ( ) : global::java.math.BigInteger
getOtherPrimeInfo ( ) : global::java.security.spec.RSAOtherPrimeInfo[]
getPrimeExponentP ( ) : global::java.math.BigInteger
getPrimeExponentQ ( ) : global::java.math.BigInteger
getPrimeP ( ) : global::java.math.BigInteger
getPrimeQ ( ) : global::java.math.BigInteger
getPublicExponent ( ) : global::java.math.BigInteger

Protected Methods

Method Description
RSAMultiPrimePrivateCrtKeySpec ( global @__env )

Private Methods

Method Description
RSAMultiPrimePrivateCrtKeySpec ( )

Method Details

RSAMultiPrimePrivateCrtKeySpec() protected method

protected RSAMultiPrimePrivateCrtKeySpec ( global @__env )
@__env global

RSAMultiPrimePrivateCrtKeySpec() public method

public RSAMultiPrimePrivateCrtKeySpec ( java arg0, java arg1, java arg2, java arg3, java arg4, java arg5, java arg6, java arg7, java arg8 )
arg0 java
arg1 java
arg2 java
arg3 java
arg4 java
arg5 java
arg6 java
arg7 java
arg8 java

getCrtCoefficient() public method

public getCrtCoefficient ( ) : global::java.math.BigInteger
return global::java.math.BigInteger

getOtherPrimeInfo() public method

public getOtherPrimeInfo ( ) : global::java.security.spec.RSAOtherPrimeInfo[]
return global::java.security.spec.RSAOtherPrimeInfo[]

getPrimeExponentP() public method

public getPrimeExponentP ( ) : global::java.math.BigInteger
return global::java.math.BigInteger

getPrimeExponentQ() public method

public getPrimeExponentQ ( ) : global::java.math.BigInteger
return global::java.math.BigInteger

getPrimeP() public method

public getPrimeP ( ) : global::java.math.BigInteger
return global::java.math.BigInteger

getPrimeQ() public method

public getPrimeQ ( ) : global::java.math.BigInteger
return global::java.math.BigInteger

getPublicExponent() public method

public getPublicExponent ( ) : global::java.math.BigInteger
return global::java.math.BigInteger