C# Class java.security.spec.DSAPrivateKeySpec

Inheritance: java.lang.Object, KeySpec
显示文件 Open project: JeroMiya/androidmono

Public Methods

Method Description
DSAPrivateKeySpec ( java arg0, java arg1, java arg2, java arg3 )
getG ( ) : global::java.math.BigInteger
getP ( ) : global::java.math.BigInteger
getQ ( ) : global::java.math.BigInteger
getX ( ) : global::java.math.BigInteger

Protected Methods

Method Description
DSAPrivateKeySpec ( global @__env )

Private Methods

Method Description
DSAPrivateKeySpec ( )

Method Details

DSAPrivateKeySpec() protected method

protected DSAPrivateKeySpec ( global @__env )
@__env global

DSAPrivateKeySpec() public method

public DSAPrivateKeySpec ( java arg0, java arg1, java arg2, java arg3 )
arg0 java
arg1 java
arg2 java
arg3 java

getG() public method

public getG ( ) : global::java.math.BigInteger
return global::java.math.BigInteger

getP() public method

public getP ( ) : global::java.math.BigInteger
return global::java.math.BigInteger

getQ() public method

public getQ ( ) : global::java.math.BigInteger
return global::java.math.BigInteger

getX() public method

public getX ( ) : global::java.math.BigInteger
return global::java.math.BigInteger